Ansicht von 12 Beiträgen - 16 bis 27 (von insgesamt 27)
  • Autor
    Beiträge
  • #1789

    micserver
    Teilnehmer

    …gut, anbei die config generiert über den Repetier online Konfigurator Development Version.
    Ausgangsbasis war die fonktionierende config der Version 0.92…
    In der 0.92er Version startete er nach „G32“ mit dem Homing und machte sich dann ans ABL, mit der Dev Version fahren x und y schnell los, nach ein paar 100ms gibts einen Reset.
    Vielleicht hast du ja einen Tip was da falsch läuft.

    Gruß, Michael

    Dateianhänge:
    1. Configuration-1.zip
    #1791

    vincent
    Keymaster

    funktioniert der Sensor mit der DEV Version? G31 gibt den Status des Sensors aus.
    Der Status muss 0 sein, wenn er nicht auslöst und 1 wenn er triggert.

    vincent.

    #1794

    micserver
    Teilnehmer

    Ja, der Sensor funktioniert:
    – nicht ausgelöst => Z-probe state:L
    – ausgelöst => Z-probe state:H

    Nur noch einmal der Vollständigkeit halber meine Vorgehensweise:
    – Online Konfigurator mit Chrome geöffnet und auf „Dev“ gesetzt
    – „alte“ funktionierende Configuration.h der 0.92er Version hochgeladen
    – Download der neuen Repetier Firmware und aufspielen mit Arduino IDE
    – am Drucker Display über „Setup“ zum „Autolevel Bett“ => OK …. läuft kurz los, bleibt abrupt stehen und resetted

    Bin für weitere Ideen zur Problemfindung dankbar.

    Gruß, Michael

    #1795

    vincent
    Keymaster

    Füge im Konfigurator im Bereich „manual additions“ folgende Zeile hinzu:
    #define FAST_COREXYZ
    Hiermit musst du aber noch die steps/mm auf X und Y Achse im EEPROM halbieren.
    Das ABL ist seit der DEV Version für lineare und nichtlineare Koordinatensystem unterschiedlich. Ich nutze mit „fast_corexyz“ nur noch das nichtlineare Koordinatensystem, da wir hiermit etwas schneller fahren können.

    vincent.

    #1796

    micserver
    Teilnehmer

    Hab’s gemacht, im EEPROM stehen auch die halbiewrten Werte, leider keinerlei Änderung:
    Über Setup das Autoleveling gestartet => er startet das Homing von x und y in gewohnter Geschwindigkeit, danach rennt er mit deutlich höherer Geschwindigkeit in y und y Richtung los, nach einigen Zentel Sekunden abrupter Stop und Reset.

    Michael

    #1797

    vincent
    Keymaster

    Ich hatte schon mal um die Konsolenausgabe gebeten. Akitivere das Logging und kopiere das bitte hier rein. Alles Andere ist wildes Raten.

    vincent.

    #1798

    micserver
    Teilnehmer

    Sorry … hier also die Ausgabe der Repetier Konsole mit der EIngabe von „G32“

    16:31:00.366 : wait
    16:31:00.366 : T:18.42 /0 B:18.95 /0 B@:0 @:0
    16:31:01.382 : G32
    16:31:01.382 : wait
    16:31:01.382 : T:18.42 /0 B:18.95 /0 B@:0 @:0
    16:31:01.554 : ok 13
    16:31:02.554 : T:18.42 /0 B:18.95 /0 B@:0 @:0
    16:31:03.648 : T:18.42 /0 B:18.95 /0 B@:0 @:0
    16:31:03.648 : busy:processing
    16:31:04.288 : T:18.25 /0 B:18.95 /0 B@:0 @:0
    16:31:05.835 : T:18.25 /0 B:18.95 /0 B@:0 @:0
    16:31:05.835 : X:300.00 Y:300.00 Z:0.000 E:0.0000
    16:31:10.304 : start
    16:31:10.304 : Info:Watchdog Reset
    16:31:10.304 : Detected EEPROM version:18
    16:31:10.304 : Transformation matrix: 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 1.000000
    16:31:13.507 : Free RAM:57532
    16:31:13.507 : Autoretract:0
    16:31:13.507 : X:0.00 Y:0.00 Z:0.000 E:0.0000
    16:31:13.507 : SelectExtruder:0
    16:31:13.507 : FlowMultiply:100
    16:31:13.507 : ok
    16:31:13.507 : ok 1
    16:31:13.507 : T:0.00 /0 B:0.00 /0 B@:0 @:0
    16:31:13.507 : ok 2
    16:31:13.507 : FIRMWARE_NAME:Repetier_1.0.0dev FIRMWARE_URL:https://github.com/repetier/Repetier-Firmware/ PROTOCOL_VERSION:1.0 MACHINE_TYPE:Core_XY EXTRUDER_COUNT:1 REPETIER_PROTOCOL:3
    16:31:13.507 : Cap:PROGRESS:1
    16:31:13.507 : Cap:AUTOREPORT_TEMP:1
    16:31:13.507 : Cap:EEPROM:1
    16:31:13.507 : Cap:AUTOLEVEL:1
    16:31:13.507 : Cap:Z_PROBE:1
    16:31:13.507 : Cap:SOFTWARE_POWER:0
    16:31:13.507 : Cap:TOGGLE_LIGHTS:0
    16:31:13.507 : Cap:PAUSESTOP:1
    16:31:13.507 : Cap:PREHEAT:1
    16:31:13.507 : Printed filament:282.94m Printing time:3 days 15 hours 1 min
    16:31:13.507 : PrinterMode:FFF
    16:31:13.507 : ok 3
    16:31:13.507 : SpeedMultiply:100
    16:31:13.507 : ok 4
    16:31:13.507 : FlowMultiply:100
    16:31:13.507 : ok 5
    16:31:13.507 : Info:No case lights
    16:31:13.507 : ok 6
    16:31:13.507 : ok 7
    16:31:13.507 : X:0.00 Y:0.00 Z:0.000 E:0.0000
    16:31:13.507 : ok 8
    16:31:13.507 : ok 9
    16:31:13.507 : DebugLevel:6
    16:31:13.507 : ok 10
    16:31:13.507 : Config:Baudrate:115200
    16:31:13.507 : Config:InputBuffer:127
    16:31:13.507 : Config:NumExtruder:1
    16:31:13.507 : Config:MixingExtruder:0
    16:31:13.507 : Config:HeatedBed:1
    16:31:13.507 : Config:SDCard:1
    16:31:13.507 : Config:Fan:1
    16:31:13.507 : Config:Fan2:0
    16:31:13.507 : Config:LCD:1
    16:31:13.507 : Config:SoftwarePowerSwitch:0
    16:31:13.507 : Config:XHomeDir:1
    16:31:13.507 : Config:YHomeDir:1
    16:31:13.507 : Config:ZHomeDir:1
    16:31:13.507 : Config:XHomePos:300.00
    16:31:13.507 : Config:YHomePos:300.00
    16:31:13.507 : Config:ZHomePos:190.000
    16:31:13.507 : Config:SupportG10G11:1
    16:31:13.507 : Config:SupportLocalFilamentchange:1
    16:31:13.507 : Config:CaseLights:0
    16:31:13.507 : Config:ZProbe:1
    16:31:13.507 : Config:Autolevel:1
    16:31:13.507 : Config:EEPROM:1
    16:31:13.507 : Config:PrintlineCache:64
    16:31:13.507 : Config:JerkXY:20.00
    16:31:13.507 : Config:KeepAliveInterval:2000
    16:31:13.507 : Config:JerkZ:0.30
    16:31:13.507 : Config:RetractionLength:3.00
    16:31:13.507 : Config:RetractionLongLength:13.00
    16:31:13.507 : Config:RetractionSpeed:40.00
    16:31:13.507 : Config:RetractionZLift:0.00
    16:31:13.507 : Config:RetractionUndoExtraLength:0.00
    16:31:13.507 : Config:RetractionUndoExtraLongLength:0.00
    16:31:13.507 : Config:RetractionUndoSpeed:20.00
    16:31:13.507 : Config:XMin:0.00
    16:31:13.507 : Config:YMin:0.00
    16:31:13.507 : Config:ZMin:0.00
    16:31:13.507 : Config:XMax:300.00
    16:31:13.507 : Config:YMax:300.00
    16:31:13.507 : Config:ZMax:190.00
    16:31:13.507 : Config:XSize:300.00
    16:31:13.507 : Config:YSize:300.00
    16:31:13.507 : Config:ZSize:190.00
    16:31:13.507 : Config:XPrintAccel:1000.00
    16:31:13.507 : Config:YPrintAccel:1000.00
    16:31:13.507 : Config:ZPrintAccel:100.00
    16:31:13.507 : Config:XTravelAccel:1000.00
    16:31:13.507 : Config:YTravelAccel:1000.00
    16:31:13.507 : Config:ZTravelAccel:100.00
    16:31:13.507 : Config:PrinterType:Cartesian
    16:31:13.507 : Config:MaxBedTemp:130
    16:31:13.507 : Config:Extr.1:Jerk:20.00
    16:31:13.507 : Config:Extr.1:MaxSpeed:50.00
    16:31:13.507 : Config:Extr.1:Acceleration:5000.00
    16:31:13.507 : Config:Extr.1:Diameter:0.00
    16:31:13.507 : Config:Extr.1:MaxTemp:290
    16:31:13.507 : ok 11
    16:31:13.585 : ok 12
    16:31:14.585 : wait
    16:31:14.679 : T:18.25 /0 B:18.95 /0 B@:0 @:0
    16:31:15.773 : wait
    16:31:15.773 : T:18.42 /0 B:18.95 /0 B@:0 @:0
    16:31:16.757 : wait

    #1800

    vincent
    Keymaster

    Siehst du das „Fertig!“ noch kurz im Display, bevor er resettet?

    #1801

    vincent
    Keymaster

    Lösche mal alles aus „Probe Start Script“ und Probe finished Script“ – du hast 290mm Z Höhe angegeben nutzt aber meinen 190mm Code. Vor dem G32 aber mit G28 homen.

    vincent.

    #1802

    micserver
    Teilnehmer

    Ausgezeichnet, jetzt läuft es <= das Löschen der Scripte hat es gebracht…
    Nur, verstanden habe ich es nicht :). Was ist in der DEV Version anders, dass der Code, der noch für die 0.92er Version galt, jetzt zu Fehlern führt?
    … und wenn, was sollte da jetzt eingetragen werden?

    Zur Höhe, welche Höhe sollte man denn als ersten Wert (bevor ein ABL gemacht wurde) eintragen bei dem Drucker mit 300er Bauhöhe?

    Sind die Punkte die ich zum Leveln nutze für die 300 x 300 Version noch sinnvoll ?

    Gruß, Michael

    #1816

    vincent
    Keymaster

    Hallo,
    Im Grunde muss da nichts stehen, du solltest vorher immer mit G28 homen. Das kannst du automatisieren, in dem du es in das Skript einträgst.

    Die Höhe minus „Z-Probe_height“ muss zwischen halber Bauraumhöhe und gesamter Bauraumhöhe liegen. Trägst du einen zu großen Wert ein, dann Fährt die Düse in das Bett. Ist der Wert kleiner als die halbe Bauraumhöhe, dann bricht das ABL ab.

    Idealerweise trägst du einen Wert ein, der ca. 10mm kleiner ist als die Bauraumhöhe, das kann man noch sicher messen.

    vincent.

    #1817

    micserver
    Teilnehmer

    Gut, mach ich so. Es ist mir aufgefallen, dass früher alles nach dem ABL gehomt wurde, jetzt bleibt er oben stehen… wäre es da nicht sinnvoll auch ein G28 in das Probe finished Script zu schreiben?
    Und welche Messpunkte trägst du im Repetier Konfigurator ein, bleibt das bei den 60/240 etc. ?

    Danke, Michael

Ansicht von 12 Beiträgen - 16 bis 27 (von insgesamt 27)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.