Schlagwörter: , ,

Ansicht von 15 Beiträgen - 136 bis 150 (von insgesamt 154)
  • Autor
    Beiträge
  • #1731

    Nobody4711
    Teilnehmer

    Morgens,

    Auch die Version 1.0.0 hat das Problem erstmal nicht behoben.

    Ich habe dann aber heraus bekommen woran es lieg. Das Problem ist das beim Fahren von Position P3 zu Position P1 der Schlitten extrem langsam Fährt, aber die Z Achse mit „normaler“ Geschwindigkeit nach oben Fährt. Das Passiert aber nur beim ersten Durchlauf. Ich habe nun den Abstand während des Z-Probe auf 40mm Distanz erhöht, so hat der Schlitten genügend Zeit bis P1 zu kommen, und dann geht es auch.

    Nun habe ich aber leider ein neues Problem, das Leveling scheint sich nicht sauber auf einen Wert einigen zu können.

    Hier das Protokoll, Ich hoffe mir kann jemand sagen was da noch Falsch ist. Ich habe hinten dran den G30 mal ausgeführt.
    12:47:13: Attempting to connect to printer
    12:47:13: Connection opened
    < 12:47:14: þÿstart
    > 12:47:14: N1 M110 *2
    > 12:47:14: N2 M110 *1
    < 12:47:14: Detected EEPROM version:18
    > 12:47:14: N3 M115 *5
    < 12:47:14: Transformation matrix: 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 1.000000
    < 12:47:17: Free RAM:3630
    < 12:47:17: SelectExtruder:0
    > 12:47:17: N5 M111 S6 *66
    > 12:47:17: N6 M111 S6 *65
    < 12:47:17: FIRMWARE_NAME:Repetier_1.0.0dev FIRMWARE_URL:https://github.com/repetier/Repetier-Firmware/ PROTOCOL_VERSION:1.0 MACHINE_TYPE:Core_XY EXTRUDER_COUNT:1 REPETIER_PROTOCOL:3
    < 12:47:17: Cap:PROGRESS:1
    < 12:47:17: Cap:AUTOREPORT_TEMP:1
    < 12:47:17: Cap:EEPROM:1
    < 12:47:17: Cap:AUTOLEVEL:1
    < 12:47:17: Cap:Z_PROBE:1
    < 12:47:17: Cap:SOFTWARE_POWER:1
    < 12:47:17: Cap:TOGGLE_LIGHTS:0
    < 12:47:17: Cap:PAUSESTOP:1
    < 12:47:17: Cap:PREHEAT:1
    < 12:47:17: Printed filament:0.00m Printing time:0 days 0 hours 0 min
    < 12:47:17: PrinterMode:FFF
    < 12:47:17: DebugLevel:6
    < 12:47:17: DebugLevel:6
    > 12:47:21: N11 M502 *52
    < 12:47:21: SelectExtruder:0
    < 12:47:21: Info:Configuration reset to defaults.
    > 12:47:24: N16 M500 *49
    < 12:47:25: Info:Configuration stored to EEPROM.
    > 12:47:29: N21 M119 *57
    < 12:47:29: endstops hit: x_max:L y_max:L z_max:L Z-probe state:L
    > 12:47:33: N26 G28 *7
    < 12:49:14: X:280.00 Y:300.00 Z:194.000 E:0.0000
    > 12:49:24: N46 G32 S2 *75
    < 12:51:23: Z-probe:39.365 X:60.00 Y:60.00
    < 12:52:03: Z-probe:38.875 X:240.00 Y:60.00
    < 12:52:43: Z-probe:37.926 X:60.00 Y:240.00
    < 12:52:43: plane: a = -0.0027 b = -0.0080 c = 40.0075
    < 12:52:44: Printer height:192.91
    < 12:52:44: CurrentZ:40.01 atZ:41.10
    < 12:53:24: Z-probe:37.969 X:60.00 Y:60.00
    < 12:54:03: Z-probe:37.938 X:240.00 Y:60.00
    < 12:54:43: Z-probe:37.819 X:60.00 Y:240.00
    < 12:54:43: plane: a = -0.0002 b = -0.0008 c = 38.0294
    < 12:54:43: Printer height:189.84
    < 12:54:43: CurrentZ:38.03 atZ:41.10
    < 12:55:26: Z-probe:40.730 X:60.00 Y:60.00
    < 12:56:08: Z-probe:40.846 X:240.00 Y:60.00
    < 12:56:51: Z-probe:40.726 X:60.00 Y:240.00
    < 12:56:51: plane: a = 0.0006 b = -0.0000 c = 40.6928
    < 12:56:51: Printer height:189.43
    < 12:56:51: CurrentZ:40.69 atZ:41.10
    < 12:57:34: Z-probe:41.273 X:60.00 Y:60.00
    < 12:58:17: Z-probe:41.247 X:240.00 Y:60.00
    < 12:59:00: Z-probe:41.186 X:60.00 Y:240.00
    < 12:59:00: plane: a = -0.0001 b = -0.0005 c = 41.3108
    < 12:59:00: Printer height:189.64
    < 12:59:00: CurrentZ:41.31 atZ:41.10
    < 12:59:42: Z-probe:40.948 X:60.00 Y:60.00
    < 13:00:25: Z-probe:41.002 X:240.00 Y:60.00
    < 13:01:08: Z-probe:40.928 X:60.00 Y:240.00
    < 13:01:08: plane: a = 0.0003 b = -0.0001 c = 40.9363
    < 13:01:08: Printer height:189.48
    < 13:01:08: CurrentZ:40.94 atZ:41.10
    < 13:01:09: X:60.00 Y:240.00 Z:40.936 E:0.0000
    > 16:44:58: N6201 G30 *15
    < 16:45:39: Z-probe:40.946 X:60.00 Y:240.00
    > 16:45:43: N6216 G30 *9
    < 16:46:25: Z-probe:40.917 X:60.00 Y:240.00
    > 16:46:26: N6228 G30 *4
    < 16:47:08: Z-probe:40.949 X:60.00 Y:240.00

    Die Configuration hänge ich auch noch mal mit an. Hardware Sparkcube XL , Ramps 1.4 mit CNC Shild 1,8 Grad 2,5Amp. Motoren, 8mm Alu Druckbett und Kapazitiver Sensor.

    Dateianhänge:
    1. Configuration.h
    #1733

    vincent
    Keymaster

    Die letzte Messung:
    < 12:59:42: Z-probe:40.948 X:60.00 Y:60.00 < 13:00:25: Z-probe:41.002 X:240.00 Y:60.00 < 13:01:08: Z-probe:40.928 X:60.00 Y:240.00 Die Abweichung beträgt unter 0,05mm und das mit einem kapazitivern Sensor. Ist doch in Ordnung. vincent.

    #1803

    Nobody4711
    Teilnehmer

    Morgens,

    nun hatte alles Funktioniert. Ich habe nun den Extruder Montiert und wollte endlich Drucken. Leider habe ich nun ein neues Problem. Der Drucker Rattert immer wieder wenn ich das mABL nutzen möchte, siehe Video

    Vorher ging es einwandfrei, Ich habe nur den Extruder Montiert und die Riemen etwas mehr gespannt.
    Die Treiber werden aktiv gekühlt.
    Ohne ausführen von mABL druckt er auch, siehe Bild.
    Leider scheint er aber nur jede zweite bahn zu Drucken am Boden, siehe Bild. Da läuft er aber Sauber.
    Was kann das Bitte sein, und wieso ist der Boden so „Löchrig“ was muss ich dafür bitte einstellen.

    Danke für eure Hilfe.

    Sparkcube V1.1 XL
    Ramps 1.4 mit CNC Shild
    NEMA 17 mit 1,8 Grad und 2,5 Amp
    12 Volt Schaltnetzteil

    Dateianhänge:
    #1805

    ghenne
    Teilnehmer

    Hallo,
    nun, wenn nichts anderes verändert wurde, dann wird’s wohl mit der geänderten Riemenspannung zu tun haben, hat sich etwas verzogen, laufen die Lager noch gleichmäßig?. Er springt und fährt ja richtig zickzack beim Anfahren der Probe Position. Was noch zu prüfen wäre ist die XY-Geschwindigkeit beim Probing (Z_PROBE_XY_SPEED). Wie schwer ist es im ausgeschalteten Zustand den Carriage zu bewegen? Wenn du den Cube auf die Seite legst, bewegt sich der Carriage noch von allein nach unten?
    Was ich sehe ist auch, dass du den Sensor nun mit dem orig. Halter befestigt hast, sind Z_PROBE_X_OFFSET und Z_PROBE_Y_OFFSET angepasst? Bei der zweiten Probe Position sieht es aus, als ob der Sensor nicht mehr über dem Bett steht, dann gibt’s einen Crash!

    LG,
    Gunnar.

    #1806

    Nobody4711
    Teilnehmer

    Eine/zwei Fragen zu Vincent Beschreibung

    – …
    – M114 und aktuelle Z Koordinate merken („Zkoord_1“)
    – 0,5mm Distanzstück unter Sensor und Bett legen und Sensor in dieser Höhe fixieren
    – in 0,1mm Schritten Z Achse nach oben fahren, bis Sensorlampe erlischt
    – Z Koordinate merken („Zkoord_2“)
    – EEPROM manuell einstellen auf:
    – „Z-probe height“ auf („Zkoord_2“ – „Zkoord_1“) // Bei 4mm Schaltabstand und PEI Druckplatte beträgt das Ergebniss ca. 0,5mm
    – „Max z-probe – bed dist“ auf 5mm

    – G28 (G1 Z10)
    – Heizbett aufheizen
    – max z probe-z dist
    – G32 S2 ;führt MABL aus und speichert korrekte Höhe als „Z max length“ im EEPROM
    – Bett ist nun ausgerichtet und muss erst wieder neu ausgerichtet werden, wenn es sich mechanisch verzogen hat
    – Für ein erneutes Ausrichten ist nur ein „G28“ und ein „G32 S2“ nötig
    – sollte der erste Layer zu hoch gedruckt werden, muss man die „Z-probe height“ verkleinern vice versa

    Morgens,

    Gilt das auch für Kapazitive Sensoren? Die gehen ja später aus als der Punkt wann Sie angehen wenn man den Punkt anfährt? oder muss man hier dann den Punkt wählen wo der Sensor auslöst?

    Wenn ich den Drucker ausgemacht habe und Ihn erneut einschalte und einen G28 mache wird doch die „Z max length“ wieder überschrieben, richtig, also muss ich dann auch wieder das mABL mit einem G32 S2 ausführen, oder kann ich den G28 auf X und Y beschränken so das die höhe gespeichert bleibt. Oder habe ich hier einen Denkfehler.

    @Gunnar:

    Danke für deine Antwort. Irgendwie hat sich ein Riemen von der Rolle bewegt, und dadurch ging der Schlitten nicht mehr weiter, nicht mal mehr mit Gewalt. Das viel beim Druck des 20x20mm Würfels nicht auf da ich nicht dahin gekommen bin.
    Jetzt habe ich nur noch das Problem mit dem Ausrichten des Druckkopfes, ich habe das Gefühl das der immer auf einer anderen höhe landet, ich bekomme den nicht sauber eingestellt. Wenn ich ihn Manuell mit der Papier Methode einstelle ohne mABL läuft er nun.

    Danke

    #1811

    Nobody4711
    Teilnehmer

    UPDATE:

    PROBLEM mit der Ermittlung von „Z-Probe height“

    Nun läuft er auch mit montiertem Hotend.das mABL durch. Nach dem zweiten Durchlauf ist der Drucker mit dem Ausrichten fertig.

    Soweit so gut. Nun habe ich versucht nach der Anleitung von Vincent den Drucker einzustellen das er nach dem mABL auch die korrekte höhe hat zum Drucken:

    Vincent hatte mal geschrieben das er einen Induktiven Sensor einsetzt, ich habe einen Kapazitiven, wenn ich das Druckbett an den Sensor fahre und der Auslöst ( G31 H ), muss ich danach fast 10mm wieder runter fahren bevor er wieder von H auf L wechselt, also sind die Ein und Ausschaltpunkte unterschiedlich. Daher habe ich bei Vincent in der Anleitung einen kleinen punkt geändert:
    „– in 0,1mm Schritten Z Achse nach oben fahren, bis Sensorlampe erlischt“
    ich habe nicht den Punkt genommen wo der Sensor ausgeht sondern von L auf H wechselt.
    Die Nacht kam mit der gedanke ob hier eventuell mein Fehler liegt, aber wenn ich das richtig verstehe benutzt REPETIER den Punkt wenn der Sensor von L auf H wechselt, und nicht wenn er von H auf L wechselt, oder liege ich hier falsch?

    Ich bin also wie oben von Vincent beschrieben vorgegangen ich hatte im EEPROM „Z_max_length = 178.528 vorher stehen. Als Wert „Zkoord_1“ hatte ich dann Z -2.183 und als „Zkoord_2“ Z -2.917 woraus sich laut Formel „Z-probe height“ auf („Zkoord_2“ – „Zkoord_1“) ein Wert von 0.734 ergibt.

    Wenn ich nun Drucke, druckt er in der Luftconfused smiley

    Die weisse Simkarte ist 0,8mm Dick, da fehlt also einiges.

    Ich hoffe das mir jemand helfen kann wo mein fehler liegt,
    Danke

    Dateianhänge:
    #1813

    ghenne
    Teilnehmer

    Hi Nobody,
    man muss sich das mal ein bisschen durchdenken, mal ne Zeichnung machen. Ich finde Vincents Anleitung auch nicht der Weisheit letzter Schluss, oder wie Vincent selber sagen würde: „völlig Banane.“. Nix für Ungut Vincent, ich schätze deine Arbeit und habe dank dir einen super Drucker bauen können 🙂

    Mir wäre dein errechneter Wert für „Z-probe height“ viel zu gering, ich hätte da Angst, dass die Düse bei geringen Messfehlern schon mal das Bett punktiert. Ich selbst habe meine „Z-probe height“ in der Firmware eingestellt (3mm) und dann, nachdem der Sensor 0,5mm höher als die Düse befestigt wurde. die Düse aufs Bett gefahren, die Position dann aufgeschrieben und wieder 3mm runterfahren, sodass die Düse dann 3mm über dem Bett war. Dann meinen dicken kapazitiven Sensor an der Einstellschraube so justiert, dass er gerade schaltet (L->H). Dann noch mehrere Durchläufe mit Bett runterfahren und wieder in 0,1mm Schritten annähern (an die 3mm)

    Wenn dein Sensor jetzt nicht einstellbar ist, dann würde ich aber trotzdem eine Z_PROBE_HEIGHT von z.B. 3mm in der Konfiguration eintragen, dann die Düse 3mm über das Bett stellen und dann den Sensor so hoch oder runter schrauben, dass er gerade triggert (L->H). Wenn du dann da in die Nähe von 3mm gekommen bist, dann kann man ja die letzten Mikrometer wieder durch vergrößern oder verkleinern der Z_PROBE_HEIGHT im EEPROM einstellen. Damit er ausreichend zurückfährt beim Probing Z_PROBE_SWITCHING_DISTANCE richtig einstellen.

    Bei den abschließenden Tests dann aber Z nicht auf 0 fahren, ein 0 Abstand lässt sich schlecht feststellen. Lieber eine 0,5mm Fühllehre unterlegen und z.B. auf 0,5 fahren.

    Grüße,
    Gunnar.

    #1814

    Nobody4711
    Teilnehmer

    Morgens Gunner,

    Danke erstmal wieder für Deine Hilfe. Glaube mir, ich habe mir was das thema angeht schon sehr viele gedanken gemacht, warscheinlich zuviele, nur passen die nicht zu denen wie es die Entwickler gelöst haben. Ich gebe zu, das ich mich sehr schwer tue das zu verstehen. Ich hätte es so Definiert das Z0 = die Düse auf dem Druckbett ist, also Kontakt. Der Sensor irgendwo zwischen 1-3 cm höher, je nach Güte des Sensors, was man dann als totale Position einträgt. Und über einen dritten Parameter hätte ich den Abstand zum Druckbett Difiniert zum Drucken.
    Aber OK, das ist was anderes.

    Ich habe mich an Vincent Seine Anleitung gehalten, das ist die einzige die ich gefunde habe wie es geht und deshalb den Sensor nur 0,5mm hoch montiert.

    Ich verstehe nicht wieso aber wenn ich die Werte so erreche ist er komplett in der Luft landet.

    Wenn ich Dich richtig verstehe, hast Du den Punkt genommen wo dein Sensor der ja auch ein Kapazitiver ist von L auf H schaltet, richtig? Ist es bei Dir auch das der Punkt von H auf L davon abweicht? Wie hast Du es berechnet. Ich habe mir eben den Text bei Repetier nochmal mit Google Translate übersetzen lassen, das ist schon hart was da raus kommt.
    Ich werde nachher nochwas ausprobieren.

    Danke Dir nochmal, es tut mir leid das ich mich warscheinlich etwas bescheuert anstelle, mir fällt vieles leichter wenn ich verstehe wie es funktioniert, aber das tue ich hier leider noch nicht, und so richtig erklären konnte es mir auch noch keiner. Es gibt zwar einige die es umgesetzt haben, aber wenn man die nach dem wie geht das Fragt, kommt da leider oft nichts brauchbares.

    #1815

    vincent
    Keymaster

    Ich werde mir wohl was ausdenken müssen…

    Problem bei der Sache ist, dass sich der gesamte Algorithmus im letzten halben Jahr bestimmt 5mal verändert hat. Jetzt gibt es zusätzlich in der DEV Version noch die „non-linear“ Kinematik, welche wiederum ein komplett anderes MABL Verhalten hat.

    Ich müsste die Basisfirmware neu konfigurieren. Die aktuellste MABL Variante bekommt ihr im Moment, wenn ihr in den manual additions „#define fast_corexyz“ definiert.

    vincent.

    #1818

    Qowaz
    Teilnehmer

    Hi.

    Ich hatte das gleiche Problem mit der Z-Probe Höhe (Height), habe gefühlte 1000 mal eingestellt und habe Vincent für seine Anleitung verflucht… 😉 Dann wurde es mir zu blöd und ich habe es ganz anders gelöst: MABL eingerichtet nach Anleitung, allerdings ohne zuletzt die Z-Probe Höhe zu definieren. Somit hat klappte das leveln des Bettes…. Dann habe ich die Z Höhe manuell vermessen mit G1 S1->G1 Z-(x). Diese Höhe habe ich dann in der FW als Z Höhe definiert. Jetzt mache ich jedesmal nur G32, ohne S1/S2 (!!!), um zu leveln, Homing all Axes, und basta… Durch den Z Max Endstop bleibt die fahrbare Z Höhe ja immer die gleiche. Ergo läuft so alles über einen kleinen Umweg wunderbar… Ich hoffe ich habe das einigermaßen verständlich rüber gebracht.

    Gruß Vasco

    #1819

    ghenne
    Teilnehmer

    Hi Vincent,

    danke für deine Worte, nur einen kleinen Tip brauche ich von dir, lohnt es sich für den Normalbürger fastcorexyz zu verwenden oder mal auszuprobieren?

    Hallo Nobody,

    ich weiss auch überhaupt nicht, wie die Diskussion auf diese H->L/L->H Geschichte gekommen ist. Die interessante Z-Koordinate ist einzig die, wo der Sensor triggert, also das nahe Bett anzeigt also meinetwegen auch von L auf H schaltet. Die Z Koordinate wo der Sensor wieder abschaltet ist fast völlig uninteressant, jedenfalls total uninteressant für die Berechnung der Z_PROBE_HEIGHT. Wie ich schon schrieb, muss die Firmware nur wissen, wie weit das Bett nach dem triggern wieder zurückgefahren werden muss, damit der Sensor sicher abschaltet und ich wiederhole mich, wenn ich sage, dass das in Z_PROBE_SWITCHING_DISTANCE eingetragen werden muss.

    Bitte bei Unklarheiten auch noch die Repetier Firmware Doku konsultieren. Das ist in einfachem Englisch gehalten, versteht jeder: https://www.repetier.com/documentation/repetier-firmware/z-probing/
    Die dort beschriebene Methode ist ganz ok, für diejenigen, die gerne rechnen. 🙂

    Nobody, wie groß ist übrigens der Schaltabstand deines Sensors, d.h. wie viele mm über dem Bett löst er aus?

    Grüße,
    Gunnar.

    #1822

    Nobody4711
    Teilnehmer

    Morgens,

    @vincent:
    Danke für Deine Antwort. Verstehe ich es Richtig, damit es überhaupt funktionien kann muss noch was eingetragen werden? Oder geht es auch noch nach der o.A. Anleitung/Einstellungen aber dann nur mit einer älteren Variante. Weil das Leveln macht er ja.

    @Vasco:
    Danke für Deine Erklärung, so ähnlich habe ich es gerstern auch gemacht, um endlich mal was zu Drucken.

    @Gunner:
    Danke für deine Antwort. Die habe ich mal ins spiel gebracht, da Vincent in seiner Anleitung schreibt wenn das Lämpchen am Sensor erlischt, was bei meinem 12mm Sensor welten auseinander liegt. Wenn der Sensor bei Z 2.700 Triggert ( Status H setzte) muss ich bis fast 10.90 zurück fahren das er wieder auf Status L zurück geht. Daher habe ich den Punkt genommen wo er Triggert beim heranfahren auslöst, was ja auch richtig zu sein scheint.

    Mein Problem ist das der Schaltabstand sich ändert, wenn ich das Blanke Alu Druckbett habe ist es fast 100mm, also nicht zu brauchen, mit der Carbon Platte Drauf sind es ca. 6mm ohne Heizung.
    Wenn ich nun die Heizung mit Einschalte hat er gestern nur noch mist gemacht, da ist kein Wert reproduzierbar.

    Also habe ich den Induktiven dran gemacht, der hat aber mit der 1,5mm Carbon Platte das Problem das er diese nicht erkennt, bei einem Schaltabstand von ca. 2mm bleibt da nicht viel, also so leider auch nicht wirklich nutzbar, und leider auch nicht Einstellbar.Dann habe ich den 18mm Kapazitiven Sensor genommen, der scheint zumindest etwas genauer zu sein als der 12mm und etwas besser auszulösen. Aber leider bekomme ich den über die einstellschraube auch nicht soweit runter geregelt das ich ca. 2-3mm höher liege als die Spitze der Nozzle. Das werden auch ehr 4-6 mm Sein. In ermangelung eines Halters habe ich nur etwas getestet, ich werde heute dafür noch einen Halter Drucken und es probieren.

    So, nur um eventuelle weitere Denkfehler auszuschliessen, ich habe da mal was gezeichnet um das ganze etwas anschaulicher zu machen.

    Wenn ich nach dem Homen ( G28 ) Manuell das Druckbett nach oben fahre, habe ich eine Höhe von Z=181,6mm bis ich Kontakt habe zwischen Nozzle und Druckbett. Der Auslösepunkt vom Z-Probe Sensor liegt bei 180,6mm. Z-Probe ist mit 2,0mm im EEPROM eingetragen. Die korrekte Höhe für den ersten Layer zum Drucken wäre bei 181,3mm in meinem Beispiel (181,6mm Kontakt Nozzle zum Druckbet abzüglich 0,3mm Papierdicke ((ich weis stimmt nicht)) würde die Höhe 181,3mm ergeben). Wenn also nach dem mABL Printer height=181,3 da stehen würde wäre es Super.

    Jetzt kommt etwas wo ich etwas Durcheinander bin, laut Vincent wird „Z-Probe_Offset“ wie folgt ermittelt ( Dicke Distanzstück für Sensor 1,3mm – Dicke Papier 0,3mm – Schaltabstand 2mm, würde bei mir einen z_Probe_offset von -1,0mm machen.
    An einer anderen stelle wird z_Probe_offset als Abstand zwischen Nozzle und Druckbett beim Auslösen des Sensors bezeichnet, was bei mir 1,0mm wären und nicht -1,0mm, oder habe ich da einen denkfehler.

    Ich hoffe ich habe es so nun korrekt wiedergegeben, wenn nicht, könnte mir bitte einer an hand meines Beispieles sagen wo ich falsch liege.. Mensch, langsam komme ich mir vor als wäre ich zu doof dafür.

    Ich danke für eure mühe und geduld mit mir.

    Ich habe die letzte Nacht gefühlt 250 mal das mABL laufen lassen. Wenn das Bett Auf

    Dateianhänge:
    #1824

    ghenne
    Teilnehmer

    Hallo Nobody,

    ich komme da nicht mehr mit. Man sollte es nicht komplizierter machen als es ist. Vor Allem musst du dir die einzelnen Parameter klar machen und auf den Repetier Seiten, die ich vorher erwähnt hatte dich informieren. Zum Beispiel sieht es so aus als verwechselst du wohl Z_PROBE_Z_OFFSET und Z_PROBE_HEIGHT. Ich hatte bisher immer von Z_PROBE_HEIGHT geschrieben und bin mir sicher das Vincent das auch getan hat. Z_PROBE_Z_OFFSET erst mal auf 0 lassen, das kommt später, wenn du über diese Möglichkeit die Dicke einer wechselnden Druckunterlage der Firmware mitteilen willst. Zuerst wechseln wir nicht. Lass deine Carbonplatte ständig drauf und mache so die ganze Kalibrierung mit der Platte. Es macht auch keinen Sinn ohne Platte auf blankes Alu zu drucken oder hast du PEI Beschichtung? Außerdem verträgt das Carbon besser die gelegentlichen Crashs mit der Düse. 🙂

    Dann verhalten sich deine Sensoren gelinde gesagt merkwürdig. Die Veränderung im Schaltabstand kann NIE 100mm betragen, dann ist etwas defekt oder etwas stört. Der 18mm kapazitive Sensor mit der Einstellschraube ist m.E. das Beste was man bekommen kann. Ich habe auch eine 1,5mm Carbonplatte, die ich mittlerweile nicht mehr verwende, da ist der Schaltabstand 0,3mm kleiner gegenüber der Alu Platte. Hier der Tipp, alle Sensoren außerhalb des Druckers mit separatem Netzteil mal zu prüfen, vielleicht ist auch in der angeschlossenen Elektronik die die Pegel wandelt ein Problem.

    Mein Vorschlag, mache mit dem 18mm Sensor weiter. Ich lade heute Abend im reprap Forum in meinem Projekt Thread mal die stl meines Halters hoch, ich hatte Vincents 12mm Halterung auf 18mm umgezeichnet.

    Also bevor es weitergeht, lies dich auf der Repetier Z-Probing Seite ein und versuche mal das Vorgehen im Abschnitt „Calibrating Z-Probe“ zu verstehen. Wenn das mit dem Englisch nicht so geht, ist auch hier Google dein Freund.

    Viele Grüße,
    Gunnar.

    #1825

    ghenne
    Teilnehmer

    noch kurz was,

    bei Google nicht die ganze Seite übersetzen lassen, das ergibt Quatsch, nur einzelne unbekannte Wörter, vielleicht auch bei Leo.org übersetzen.
    Dann besorg dir eine Fühllehre, kein Papier verwenden.

    #1826

    Nobody4711
    Teilnehmer

    Morgens Gunner,

    danke für Deine Mühe.

    Vincent hatte es hier ganz am anfang beschrieben im Post 1050, daher habe ich das.
    ————————-
    st es jetzt schon wichtig an welche treiber ich die Z Motoren hänge oder ist das egal solange es getrennte sind?

    Im Grunde ist es egal, ich würde jedem allerdings raten, die Motoren in der gleichen Reihenfolge zu verkabeln, wie es dann in der veröffentlichten Firmware mit MABL sein wird.

    ABL Sensor an der Carriage:

    1. Bett sollte einigermaßen ausgerichtet sein
    2. Druckbett so dicht an die Düse fahren, dass ein Blatt Papier dazwischen schleift
    3. ABL Sensor so befestigen (Feineinstellung = den Sensor drehen) dass ein ca. 1-2mm dickes Distanzstück schleifend zwischen Bett und Sensor passt

    „Z-Probe offset“ ist nun (Dicke Distanzstück – Dicke Papier)
    Bei den ersten Ausdrucken kann man dann den Offset noch leicht verändern um die Höhe der ersten Schicht noch nachzuregeln.

    Bei berührungslosen ABL Sensoren ist der Schaltabstand von dem Ergebnis noch abzuziehen:
    (Dicke Distanzstück – Dicke Papier)-Schaltabstand

    vincent.
    ————————————–
    Ja, das Verhalten von dem 12mm Sensor ist komisch, da ich bisher nur mit den Induktiven Sensor erfahrung hatte mit meinem Printrbot und man oft liest das die Kapazitiven ungenauer währen war ich erstmal nicht beunruhigt, zumal vincent die ergebnisse gut fand. Daher werde ich nun den 18mm Verbauen.

    Die Carbon Platte bleibt auch drauf, ist als Wechselplatte gedacht, ich habe 3 Stück davon, auf was anderem wollte ich erstmal nicht Drucken, die Builtak hält zwar gut, aber immer wieder habe ich das Problem das Zeug runter zu bekommen, das möchte ich mir so gerne ersparen. Da ich noch den Schlitten von Wurstnase nutze muss ich den Winkel etwas anpassen damit der Sensor Senkrecht zur Platte steht.

    Ich suche mir gleich mal deinen Projekt Trade raus.

    Danke nochmal

    • Diese Antwort wurde geändert vor 1 Monat, 3 Wochen von  Nobody4711.
Ansicht von 15 Beiträgen - 136 bis 150 (von insgesamt 154)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.