Ansicht von 7 Beiträgen - 1 bis 7 (von insgesamt 7)
  • Autor
    Beiträge
  • #1486
    moelski
    Teilnehmer

    Moin !

    Ich bin nun ca. 2 Wochen in der XL „Gemeinde“ und komme von meinem betagten Prusa I3. Und ich muss sagen der SparkCube ist eine Augenweide – sowohl beim Durcken als auch vom Design 🙂

    Aber es gibt da zwei Dinge die mir im Moment arg den Spass verderben.
    1) Sporadische Resets vom RADDS
    Dieser Fehler ärgert mich jetzt seit Anfang an. Öfter wenn ich längere Sachen Drucke (irgendwas >2h Druckzeit) macht RADDS einen Reset und der Druck ist hin. Das hatte ich jett sicher schon 4-5x und mir graut inzwischen davor den Drucker länger Aktiv zu haben.
    Ich habe auch leider dieses Verhalten noch nicht Live gesehen. Leider immer in meiner Abwesenheit passiert.
    Was ich aber sagen kann … Der Server (Raspi 2B+ mit dem Spark Image) läuft weiter. Wenn ich Uptime ansehe hat der keinen Reset gemacht. Der Druckkopf fährt bei Y auf home, bei X nicht (oder er fährt ein Stück von Home weg). Z bleibt einfach stehen und macht def kein Home. Das bleibt auf der letzten Position stehen. Im Display steht dann für den Z Wert 0.
    Habe schon diverse sachen überlegt was es sein könnte:
    * Netzteil zu schwach, aber dann müsste der Raspi auch resetten, weil der hängt am selben Netzteil
    * Hardware Problem mit dem DUE Board. Habe da so einen China Clone. Evtl. hat der eine Macke …
    * keine Daten vom Repetier Server? Siehe da auch Problem zwei. Weiss nicht ob die Firmware da sowas wie einen Watchdog hat der überwacht ob genug Daten kommen …
    * gcode Files hinüber? Habde den Pi sträflicherweise die ersten Male immer direkt ausgeschaltet und nicht sauber runter gefahren. Evtl. Filesystem hin? Erklärt aber auch nicht wirklich den Reset
    * Software Bug oder Speicher Überlauf am DUE? Das ist ja noch meine eheste Vermutung. Nur wie kann ich das testen …
    * Probleme mit den Treibern am RADDS. Das Radds Bord ist bei mir unter die große Abdeckplatte unterm Druckbett geschraubt. Könnte es sein das es da einen Hitzestau gibt und die Treiber aussteigen? Dagegen spricht allerdings auch das der Drucker dann in Summe stehen bleibt … Treiber sind übrigens die RAPS128.

    Tja bin da im Moment etwas ratlos. Evtl. weiss hier jemand Rat.
    Im Repetier Forum habe ich das auch gepostet:
    https://forum.repetier.com/discussion/2686/radds-printer-often-stops-for-a-short-time-while-printing-fast#latest

    2) Aussetzer beim Drucken
    Kommen wir auch gleich zu problem zwei – evtl. hängen die sogar zusammen?
    Mein Drucker hat immer wieder kleine Aussetzer vor allem wenn er viele kleine Strecken drucken muss (bsp. Rundungen). Im Display gibt es einen Wert „PUF“. Der läuft dann immer gegen 0 und dann stockt es. Soweit ich das verstanden habe ich das der Buffer an nächsten gcode Zeilen. Und laut Repetier Forum sollen in dem Fall nicht schnell genug neue Daten am RADDS ankommen. Angeblich wegen Latenz Zeiten des USB/Seriell Adapters. Irgendwie kann ich das nicht so recht glauben.
    Bin ich der einzige dem das bis dato aufgefallen ist? Bei mir erzeugt das nämlich vor allem an den Aussenkanten hässliche kleine Blobs.
    Aber wie schon bei Problem 1 beschrieben … Evtl. hängt das auch zusammen? Möglich das mein Board einfach eine Macke hat?
    Auch dieses Problem habe ich im Repetier Forum angesprochen:
    https://forum.repetier.com/discussion/2713/printer-resets-after-1hour-printing#latest

    Drum mal hier in die Runde gefragt .. Was kann ich jetzt machen? Wie kann ich die Fehler eingrenzen / untersuchen?
    Weil der schönste SparkCube nutzt mir gonix wenn ich bei jedem längeren Druck fürchten muss das er abbricht 🙁

    Grüße Dominik

    • Dieses Thema wurde geändert vor 4 Jahre von moelski.
    • Dieses Thema wurde geändert vor 4 Jahre von moelski.
    #1489
    moelski
    Teilnehmer

    Problem 1 liegt wohl an einem Watchdog Reset:
    > 7:14:39.403: start
    > 7:14:39.404: Info:Watchdog Reset
    > 7:14:39.404: Transformation matrix: 1.000000 0.000000 0.000000 0.000000
    > 1.000000 0.000000 0.000000 0.000000 1.000000
    < 7:14:39.405: N1 M117 ETE 03:34:31

    Nur was könnte den Watchdog auslösen?

    #1490
    vincent
    Verwalter

    Dieses Problem herrschte vor vielen Monaten, wurde aber erfolgreich beseitigt. Ich höre zum ersten mal wieder davon. Hast du die neuste Firmware vom DEV Konfigurator erstellen lassen?

    vincent.

    #1491
    vincent
    Verwalter

    Für das 2te Problem: setze in deinem Slic3r die Resolution auf 0.07mm
    vincent.

    #1492
    moelski
    Teilnehmer

    Moin Vincent,

    Hast du die neuste Firmware vom DEV Konfigurator erstellen lassen?
    Nein ich habe eine 0.92 Firmware bei mir in Betrieb.
    Soll ich dann die 1.0.0 DEV nehmen und der Fehler mit den Watchdog Resets ist weg?

    setze in deinem Slic3r die Resolution auf 0.07mm
    Kannst du mir da mal kurz den Zusammenhang erklären? Und weisst du wo ich das in Simplyfy3D setze? Ich nutze kein Slic3r …

    Grüße Dominik

    • Diese Antwort wurde geändert vor 4 Jahre von moelski.
    #1493
    moelski
    Teilnehmer

    Und gleich noch eine Frage wenn ich auf 1.0.0 soll …
    Kann ich meine aktuelle Config übernehmen oder muss ich irgendwo grundlegend was anpassen?

    #1495
    vincent
    Verwalter

    Soll ich dann die 1.0.0 DEV nehmen und der Fehler mit den Watchdog Resets ist weg?

    Es gab viele 0.92er Versionen einige mit dem Watchdog Fehler einige ohne. Die DEV Version hat den Fehler nicht mehr. Die configuration.h ist bis auf die Funktionen, die neu hinzu gekommen sind kompatibel.

    Kannst du mir da mal kurz den Zusammenhang erklären? Und weisst du wo ich das in Simplyfy3D setze?

    eine STL Datei kennt keine Kurven. Rundungen werden als kurze Liniensegmente dargestellt. Wenn im Slic3r keine Resolution eingestellt ist, dann nimmt er jedes STL Liniensegment als G-Code Liniensegment. Je nach Auflösung der STL Datei sind dass dann aber zu viele Informationen für die Serielle Übertragung. Wenn du die Resolution auf 0,05 bis 0,1 stellst, werden die Liniensegmente reduziert bis maximal diese Abweichung entsteht. So wird der G-Code kleiner und die Serielle Schnittstelle schaftt die Datenrate.
    Das geht bei simplify bestimmt auch, wo kann ich dir aber nicht sagen.

    vincent.

Ansicht von 7 Beiträgen - 1 bis 7 (von insgesamt 7)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.