Ansicht von 10 Beiträgen - 1 bis 10 (von insgesamt 10)
  • Autor
    Beiträge
  • #3356
    dieter-417
    Teilnehmer

    Hallo
    Der Aufbau des Spakcubes 2 steht soweit fertig im Keller,
    soweit funktionsfähig, allerdings ohne funktionierenden Bltouch (original).
    Das Radds war ein altes 1.2.
    Zwischenzeitlich hatte ich aus Frust eine Lösung mit dem Sensor des Predators gebastelt,
    aber das gefällt mir nicht.
    Also Radds 1.6 gekauft, verkabelt und die Original Software aus dem Download Verzeichnis genommen.
    Die einzige Änderung betraf das 20*4 Display.
    Nachdem Aufspielen der Firmware das selbe Spiel,
    der Stift fährt 2 mal aus, die LED de BLtouch bleibt rot und keine Reaktion
    auf Kommandos in Pronterface.
    Mittlerweile bin ich ziemlich frustriert,
    da ich einfach nicht mehr weiter weiß.
    Der Test ist nur mit einem Due, Radds, Display und BLtouch
    ohne weitere Komponenten , Stromversorgung über USB.
    Vielleicht kann mir jemand helfen
    Vielen Dank Dieter

    • Dieses Thema wurde geändert vor 3 Monaten, 2 Wochen von dieter-417.
    #3358
    vincent
    Verwalter

    Hallo Dieter,

    lade bitte mal deine config.h Datei hier hoch und schreibe genau welche Version BLTouch du hast. Es gibt je nach Version verschiedene Servo Timings, wenn die Verkabelung passt, liegt da bestimmt der Fehler.

    vincent.

    #3359
    dieter-417
    Teilnehmer

    Hallo Vincent
    Der BLtouch ist Version smart V3.1,
    mfG Dieter

    Attachments:
    #3363
    vincent
    Verwalter

    Der Test ist nur mit einem Due, Radds, Display und BLtouch
    ohne weitere Komponenten , Stromversorgung über USB.

    Das hatte ich überlesen, der BLTouch kann nur in einem funktionsfähigen System eingerichtet werden. Die Firmware überprüft etliche Parameter, sobald eine Sache keinen Sinn ergibt schaltet die Firmware in einen Notmodus , das sollte in der Kommandzeile von Pronterface aber stehen. Parameter sind z.b.: Temperaturen und Homing Status.

    Wie versorgst du den BLTouch 5V Pin mit Spannung am RADDS?

    vincent.

    #3364
    dieter-417
    Teilnehmer

    Hallo Vincent
    Vielen Dank für Deine Hilfe
    Ich hatte eine 5V Leitung von der Aux Leiste gezogen.
    Da ich von der Masse der 12V Einspeisung zu den Servo Pins einen Widerstand gemessen habe,
    habe ich auch eine Leitung von der Masse der Aux Leiste gezogen.
    Mit dem Umbau habe ich begonnen und werde nach der Fertigstellung berichten.
    Eine Frage hätte ich noch,
    sollte es nicht funktionieren müsste ich doch mit einem alten Analogoszi
    zwischen dem Servosignal und Masse,
    bei Befehlseingabe, ein Signal bekommen.
    Entschuldige die Frage, aber mit Elektronik habe ich mich in den letzten 40 Jahren kaum noch beschäftigt.
    mfG Dieter

    #3365
    vincent
    Verwalter

    Ich empfehle den BLTouch immer extern mit 5V zu versorgen. Z.b. mit einem 5V Spannungsregler, welchen man an das Netzteil anschließt. Wenn man den DUE nur per USB verbindet, hängt es vom USB Kabel und der USB Quelle ab, ob die Spannung wirklich stabil bleibt. Der BLTouch braucht 300mA Spitzenstrom.

    Mit den Befehlen sollte, wenn alles andere betriebsbereit ist, der Pin aus und einfahren:

    M340 P0 S647 ;Pin raus
    M340 P0 S1473 ;Pin rein

    vincent.

    #3366
    dieter-417
    Teilnehmer

    Hallo Vincent
    Die Versuche blieben erfolglos,
    auch die externe Versorgung mit 5V (Step down)
    Um alle möglichen Fehlerquellen auszuschliessen
    BlTouch, Radds, Due, Firmware
    habe ich den BLTouch mit einem Arduino überprüft.
    Er funktioniert tadellos.
    Ein neuer Due ist bestellt.
    Ich werde weiter berichten
    mfG Dieter

    #3367
    vincent
    Verwalter

    Hallo Dieter, beschreibe doch mal bitte genauer was du machst und was nicht funktioniert.

    Bewegt sich denn der BLTouch mit den 2 manuellen Befehlen?

    M340 P0 S647 ;Pin raus
    und
    M340 P0 S1473 ;Pin rein

    vincent.

    #3368
    dieter-417
    Teilnehmer

    Hallo Vincent
    Der BlTouch reagiert auf keinen Befehl.
    Heute werde ich mit einer LED +Widerstand überprüfen
    ob überhaupt ein Signal ausgegeben wird.
    mfG Dieter

    #3369
    dieter-417
    Teilnehmer

    Hallo Vincent
    Mit dem neuen Due funktioniert der BLTouch einwandfrei.
    Es ist interessant die beiden zu vergleichen, bevor der alte im Müll landete,
    (müsste auch schon 6-7 Jahre alt sein, und ich weiß nicht mehr wo ich den gekauft habe)
    die Verarbeitung ist viel saubererer, alles präziser gefertigt.
    Jetzt wird die komplette Verkabelung neu gemacht, bis jetzt Kabelkette,
    um eine ähnlich cleane Optik wie auf Deiner Homepage zu erreichen.
    Nochmals vielen Dank
    Dieter

Ansicht von 10 Beiträgen - 1 bis 10 (von insgesamt 10)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.