Ansicht von 6 Beiträgen - 1 bis 6 (von insgesamt 6)
  • Autor
    Beiträge
  • #2628

    steffor
    Teilnehmer

    Hallo! Ich bin leider absoluter Neuling und hab mich trotzallem an dieses, für mich, grosse Projekt gewagt. Ich habe den Drucker bisher mechanisch komplett aufgebaut und elektronisch verkabelt. Nun gehts an den Anschluss auf dem Board. Ich verwende kein MABL und FTS.
    Vincent hat in seiner Dropbox eine Anschlussplanbelegung fürs Board gepostet. Das ist auch schön und gut, allerdings wüsste ich gerne bei den Z-Motoren, welcher dort z-motor 1, z-motor 2 und z-motor 3 ist. hab jetzt einfach mal den z-motor „mitte hinten“ auf den steckplatz E3 gesteckt und den linken und rechten Motor auf den Z Steckplatz. Mein extruder geht auf den steckplatz E1.

    Hab mir dann gestern eine Firmware konfiguriert, mit der ich die x und y motoren über den repetier host schonmal zum fahren kriege. Z funktioniert leider nicht. Hab ich irgendwas vergessen/falsch angeschlossen? ich hänge meine configuration.h mal an… wie gesagt, bin ein absoluter neuling und stosse langsam an meine grenzen.

    LG

    Dateianhänge:
    1. Configuration.h
    #2630

    vincent
    Keymaster

    Hallo Steffen,

    damit sich mehrere Motoren gleich drehen, braucht es einen Haken bei:

    „Mirror motor signals to other stepper driver (FEATURE_TWO_ZSTEPPER)“

    und den korrekten Steckplatz bei:

    „Mirror stepper socket“

    die Bezeichnung in der Firmware ist anders als der Aufschrift auf dem RADDS Board:

    RADDS = Firmware
    E1 = E0
    E2 = E1
    E3 = E2

    Soweit scheint bei dir also alles richtig angeschlossen.
    Prüfe mal mit dem Befehl „M119“ ob die Endstops alle korrekt erkannt werden. Unbetätigt müssen die ein „L“ zurückgeben.

    vincent.

    #2631

    steffor
    Teilnehmer

    Danke! Ich habs nun hingekriegt. Homing in X und Y Richtung funktioniert einwandfrei (heisst: er fährt bis endstop, stoppt und fährt wieder n mm vor). Das problem bleibt wieder bei der Z Achse. sobald ich beim repetierhost auf homen drücke, dreht der motor den ich auf den e3 steckplatz gelegt habe viiiel schneller als die andern und somit wird das bett das druckbett verzogen bzw er bricht irgendwann ab, da er einfach nur mehr weiterkommt. wenn ich im repetierhost auf manuelle steuerung gehe und die z achse rauf und runter bewege, dann drehen alle motoren gleichmäßig.

    und wie funktioniert das, der firmware zu sagen „wie gross der drucker ist“.
    Beispiel: X steht nach homing auf 195. ich bewege in x richtung bis x = 0 steht -> der extruder steht auf 3/4 des druckbetts und lässt sich nicht weiter in richtung x fahren. dasselbe bei x. hat das was mit den steps zu tun?

    #2632

    vincent
    Keymaster

    Die Mikroschritteinstellung auf dem RADDS Board muss für alle Motoren gleich eingestellt sein. (Die kleinen DIP Schalter auf der Unterseite des RADDS) Achtung: Die obere und untere Reihe ist gespiegelt.
    http://doku.radds.org/documentation/#gallery-6

    Wenn die Position nach dem Homing auf 195 steht: Hast du evtl. die Firmware vom kleinen sparkcube als Basis genommen?

    Du musst dem sparkcube zwei Dinge beibringen: Wo steht der Endstop (295) und wie viele steps/mm. Beides musst du in den EEPROM Einstellung vom Repetier Host vornehmen. Das wird in das RADDS gespeichert und bleibt dort auch nach einem Firmware Flash stehen.

    vincent.

    #2651

    steffor
    Teilnehmer

    Hallo! Ein kleines update…
    ER DRUCKT! 🙂

    Ein ziemliches Erfolgserlebnis für mich.
    Ein Problem bleibt allerdings noch. Und zwar geht es um den Druckbereich des Druckers. Im RepetierHost kann ich das Druckbett einstellen, leider komme ich aber damit nicht klar und könnte jetzt noch ein letztes mal Hilfe gebrauchen. Ich habe 2 Bilder angehängt und hoffe nun ist klar was ich meine. Letztendlich druckt er nicht da, wo ich ich das Objekt ablege sondern dann (aufm dem Bild) im weissen Kreis etwa.

    Nächste Frage wäre jetzt noch, wie ich den näherungssensor in Betrieb nehmen kann. Ich habe eine DC/DC Coonverter gekauft, damit ich die Spannung auf Arduinofreundliche Volt bringen kann. Gibt es vllt einen Schaltplan wie ich das verdrahten muss und welche Adern man nehmen muss? Finde beim googlen leider nur was mit Octokopplern, in deiner BOM @vincent steht aber auch, das man einen Spannungsteiler nehmen kann um den Näherungssensor anzuschliessen.

    Würde mich um Antwort und Hilfe sehr freuen!
    Danke schonmal 🙂

    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von  steffor.
    #2655

    vincent
    Keymaster

    Die Einstellungen im Screenshot sind nur für die grafische Darstellung im Repetier Host. Für den Drucker musst du das im EEPROM einstellen. Du findest im Repetier Host und im Server „EEPROM-Einstellungen“ Hier musst du „X/Y/Z min Pos“ und „X/Y/Z max length“ einstellen.

    X min Pos: 0
    Y min Pos: 0
    Z min Pos: 0
    X max length: 300
    Y max length: 300
    Z max length: ca. 200 (ja nach Bettlevel)

    wenn es dann noch nicht passt, stimmen die „steps/mm“ nicht.

    vincent.

Ansicht von 6 Beiträgen - 1 bis 6 (von insgesamt 6)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.