Ansicht von 6 Beiträgen - 1 bis 6 (von insgesamt 6)
  • Autor
    Beiträge
  • #3327
    Lars258
    Teilnehmer

    Guten Morgen zusammen,

    ich finde keinen Thread, der ähnliche Themen behandelt zu denen ich Fragen haben. Falles es ihn gibt, bitte verlinken und diesen schließen.

    Grundsätzlich hier erstmal nur eine grobe Fehlerbeschreibung von mir. Ich weiß nicht, welche detaillierten Infos benötigt werden. Will euch mit Screenshots etc. nicht zumüllen.

    Ich habe den Sparkcube 1.1XL nun soweit mechanisch aufgebaut.

    Auf das Arduino habe ich die Dateien aus der Dropbox -> Repetier-Firmware mit FTS gespielt. Inkl. im Arduino Studio das zusätzliche Board einfügen und Repetier auswählen unter “Boards”.
    Dann habe ich mir den Repetier Server 0.92.3 auf meinen PC geladen und bin über localhost auf den Server und aus der Config.h den Drucker erstellt.

    Sobald ich per Nativ Port des Due mit dem PC verbunden bin steht der Drucker als “verbunden”. Nach gefühlten 40 Sekunden bricht die Verbindung für ca. 5 Sekunden ab. Dies wiederholt sich. USB Kabel wurde getauscht.

    Zusätzlich: Das Sparklab LCD Display leuchtet, zeigt aber nichts an. Hier habe ich in den FEATURE_UI_CONTROLLER in der config.h nicht gefunden. Per https://www.repetier.com/firmware/v092/ habe ich die Config.h geändert, sodass unter UserInterface ->Display Controller einmal “sparkLCD” und einmal “sparkLCD + Adapter on RADDS LCD Port” stand. Brachte beides das selbe Ergebnis. Ich vermute mal, dass “sparkLCD” aber die richtige Einstellung ist, das ich kein Adapter Board habe.

    Wie gesagt: Vielleicht gibt es ähnliche Probleme, die bereits in anderen Threads gelöst wurden. Welche Informationen (Screenshots, Log Files etc.) werden benötigt, um bei diesen – Anfänger – Problemen zu helfen.

    Ganz ganz herzlichen Dank

    Lars

    #3329
    vincent
    Verwalter

    Hallo Lars,

    die 0.92.3, ist ziemlich alt. Lade deine config.h mal hier im aktuellen Konfigurator hoch und lade im letzten Reiter die gesamte Firmware neu herunter:
    https://www.repetier.com/firmware/dev/index.php

    Normalerweise verbindet man den Drucker über Programming Port mit dem PC auch zum Ansteuern. Native Port funktioniert ähnlich, muss aber in der FIrmware eingestellt werden.

    Die Auswahl “sparkLCD” ist korrekt. Kontrolliere mal die Kabel, ob auch keine Adern zwischen den Steckern vertauscht sind. Das kam schonmal vor.

    vincent.

    #3330
    Lars258
    Teilnehmer

    Danke! Habe nicht mit einer so schnellen Antwort gerechnet. Komme – berufsbedingt – erst Donnerstag wieder an den Drucker.

    Ich werde dann den Link oben benutzen und die Config.h (die Dropbox Datei wurde nicht geändert) dort einladen. Unter UserInterface stelle ich “SparkLCD” ein. Danach Downloade ich die komplette Firmeware “Download complete firmware incl. these settings” und benutze die Repetier.ino im Arduino Studio.
    Muss ich unter Boards bzw unter Appdata/Roaming das Board auch einfügen oder geht das noch mit dem “alten” SAM Board?

    Bei weiteren Problemen halte ich euch auf dem Laufenden / Lade die Config.h hoch bzw. Datein, die benötigt werden.

    Danke nochmal

    Lars

    #3331
    vincent
    Verwalter

    Das manuelle Einfügen der Boardfiles ist nicht mehr nötig. Einfach die letzte Arduino Version Installieren und im Programm selber mit Hilfe des “Boardverwalters” das “Arduino SAM” Paket installieren.

    vincent.

    #3332
    Lars258
    Teilnehmer

    Ich musste noch das die SAM Board Version 1.6.5 anstatt 1.6.4 runterladen und dort die Files austauschen. Hat aber geklappt. Danke
    schön.

    Habe Repetier Server 1.0.3 auf ein Raspberry gespielt. Habe nun eine stabile Verbindung

    Das Display läuft auch, ist aber auf dem Kopf. Ist es möglich das per Software zu drehen?

    Ich bin dabei die Achsen in Betrieb zunehmen. Die Z Achsen laufen entgegen gesetzt. In den Settings habe ich entsprechenden Eintrag gefunden. Wie bekomme ich die Datein am cleversten auf den Drucker? Jedes mal das komplette Programm runter laden und auf per Arduino Studio aufspielen? Oder gibt es elegantere Wege?

    Nochmal: Falls es zur Grundinbetriebnahme bereits Threads gibt, kann ich die auch gerne durcharbeiten.

    Danke!

    Lars

    #3333
    Lars258
    Teilnehmer

    Mit ein bisschen rumspielen hab ich es hinbekommen.

    Das Display läuft auch, ist aber auf dem Kopf. Ist es möglich das per Software zu drehen?

    Selbst wenn, ich habe es gedreht

    Ich bin dabei die Achsen in Betrieb zunehmen. Die Z Achsen laufen entgegen gesetzt. In den Settings habe ich entsprechenden Eintrag gefunden

    Habe den Stecker einfach gedreht.

    Rest wird jetzt ein rumspielen und testen sein.

    Lars

Ansicht von 6 Beiträgen - 1 bis 6 (von insgesamt 6)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.