Ansicht von 11 Beiträgen - 1 bis 11 (von insgesamt 11)
  • Autor
    Beiträge
  • #1078
    Phgeis
    Teilnehmer

    Es ist soweit… er läuft!
    Mein XList aufgebaut und alle Motoren laufen.. Mabl und autolevel müssen noch feingetuned werden. aber nun meine Frage:

    Gibt es einen “Rumpf” oder Standard Start und End G-code ?

    Welche Befehle sind ein Muss? Was ist Sinnvoll? Kann mir jemand mal eine Arbeitsgrundlage, am besten natürlich kommentiert ;-), posten?

    Danke Philipp

    #1085
    vincent
    Verwalter

    Das ist mein Slic3r Start G-Code:

    
    ;@nosize
    M140 S[first_layer_bed_temperature] ; Bettemp an
    M104 S120 ;  extruder vorheizen
    G28 ;home
    G1 X190 Y0 Z1 F2000; Düse in Bettnähe
    M190 S[first_layer_bed_temperature] ; warte auf Betttemp
    M109 S275; warte auf Extrudertemp
    G1 Z0.25 F200
    G92 E0; reset extrusion distance
    G1 X190 Y0
    G1 X190 E7 ;extrudiere
    G1 X145 E15; abstreifen
    M513 ; FTS Reset
    ;@size
    

    Der Start G-Code macht mit einer kleinen Wurst am Rand des Druckbettes die Düse vor dem Druck sauber, der Skirt vom Slic3r ist damit unnötig.

    vincent.

    #1132
    Phgeis
    Teilnehmer

    Okay, mein S3D Code wollte ich so anlegen:

    M140 S[bed0_temperature]
    M104 S150
    G28 ; home all axes
    G1 X1 Y1 Z5; Abstand zum HPB 5m vorne links
    G92 E0 ;E auf 0 stellen
    M104 S[extruder0_temperature]
    G1 Z0.2; auf 0.2 ans Bett ranfahren
    G1 X1 E6 ; extrudiere
    G1 X60 Z0.1 E15; abstreifen und auf 0.1 ranfahren
    M513 ; Fts Reset

    Macht das Sinn? klappt so dass schon während des homens geheizt wird? oder heizt er erst und homed dann? Kann das momentan nich tausprobieren

    Philipp

    #1133
    Phgeis
    Teilnehmer

    Hmm hat nicht funktioniert, keine Wurst nur schnelle Bewegungen, komme jetzt nicht an den Drucker aber wie sieht das hier aus?

    M140 S[bed0_temperature] ;
    M104 S150 ;
    G28 ; home all axes
    G1 X1 Y1 Z5 ; Abstand zum HPB 5m vorne links
    G92 E0 ; E auf 0 stellen
    M104 S[extruder0_temperature]
    G1 Z0.2 ; auf 0.2 ans Bett ranfahren
    M190 S[bed0_temperature] ; Heize Bett und warte
    M109 S[extruder0_temperature] ; heize extruder und warte
    G1 X1 E6 F200 ; extrudiere
    G1 X60 E15 ; abstreifen
    M513 ; Fts reset

    #1141
    Phgeis
    Teilnehmer

    Um das Thema von meiner Seite aus Abzuschliessen:

    Ich bin nun mit diesem Startcode in S3D zufrieden

    M140 S[bed0_temperature]
    M104 S150
    G28 ; home all axes
    G1 X0
    G1 Y0
    G1 Z5; Abstand zum HPB 5m vorne links
    G92 E0 ; E auf 0 stellen
    M190 S[bed0_temperature] ;
    M109 S[extruder0_temperature] ;
    G1 Z0.2 ; auf 0.2 ans Bett ranfahren
    G1 X1 E6 F200 ; extrudiere
    G1 X60 E15; abstreifen
    G1 X65
    M513 ; Fts reset

    #1142
    vincent
    Verwalter

    Hallo Philipp,

    das nächste mal, sollten wir gleich zu Beginn klären, für welchen Slicer der Start G-Code ist. Mein Vorschlag galt nämlich slic3r. 🙂

    vincent.

    #1457
    derAndi
    Teilnehmer

    Hallo, darf ich das Thema nochmal aufgreifen?
    Bin auch noch auf der Suche nach dem perfekten startcode. Habe Repetier drauf.
    Der o.g. code von slic3er funktioniert bei mir nur halb. Also er heizt, extrudiert, streift schön ab,
    aber dann homed er wieder, und beginnt kurz danach mit dem drucken. In der Zeit hab ich dann natürlich
    wieder oozing.
    Hat zufällig jemand einen code parat, der hilfreich sein kann?
    Vielen Dank,
    Andi

    #1465
    vincent
    Verwalter

    Hallo Andi,

    lade doch mal einen Beispielhaften GCode hoch, bei dem der Fehler auftritt. Dann sehe ich wo er homed.
    vincent.

    #1474
    derAndi
    Teilnehmer

    Hallo Vincent,
    ich habe genau den Code von Dir aus dem ersten Post verwendet, und etwas abgeändert

    M140 S60 ; Bettemp an
    M104 S200 ;  extruder vorheizen
    G28 ;home
    G1 X190 Y0 Z1 F2000; Düse in Bettnähe
    M190 S60 ; warte auf Betttemp
    M109 S200; warte auf Extrudertemp
    G1 Z0.25 F200
    G92 E0; reset extrusion distance
    G1 X190 Y0
    G1 X190 E7 ;extrudiere
    G1 X145 E15; abstreifen

    Danach fährt er wieder heim, und fängt dann erst zu drucken an. Ich stell das heut abend nochmal nach, und melde mich wieder.

    #1480
    derAndi
    Teilnehmer

    so, also, es läuft so ab:
    er fährt nach vorne rechts, paar mm über das bett und heizt den extruder, dann wenn er bei der temp ist, geht er direkt aufs bett runter, macht nen streifen, homed wieder, fährt das bett etwas runter, und fängt dann nach paar sec an zu drucken.

    #1481
    vincent
    Verwalter

    Hallo Andi,

    bitte lade doch mal deine G-Code hoch, nicht nur den Start G-Code. Welchen Slicer verwendest du?

    vincent.

Ansicht von 11 Beiträgen - 1 bis 11 (von insgesamt 11)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.