Ansicht von 11 Beiträgen - 1 bis 11 (von insgesamt 11)
  • Autor
    Beiträge
  • #1513
    ghenne
    Teilnehmer

    Hallo Vincent,

    ich habe das case light im Repetier Konfigurator aktiviert. Als Pin habe ich Heater3 genommen (Arduino Pin 11), es wird nach Einschalten aktiviert.
    Das geht auch, aber ca. 2 Sekunden nach dem Einschalten des Netzteils geht der LED Streifen wieder aus. Wenn ich dann über das Schnelleinstellungen Menü Lampen einschalten will, blitzt der LED Streifen nur kurz auf.

    Kann es sein das der Anschluss Heater3 irgendwie schon belegt ist? Laut Verdrahtungsplan in der Dropbox ist der frei aber in der configuration.h finde ich das:

    #undef FAN_PIN
    #define FAN_PIN HEATER_3_PIN

    Was ist das? Die Fans sind doch an Arduino Pin 8 und 9?

    Bitte um Hilfe.

    #1514
    ghenne
    Teilnehmer

    Noch infos dazu: ich habe das RADDS 1.5 Arduino Due und die Configuration.h die hier für MABL ohne Extension Board zu finden war.

    #1515
    ghenne
    Teilnehmer

    Moin Moin,
    nachdem ich mich mit dem Problem nun ziemlich allein gelassen fühle, habe ich schnell mal auf HEATER_2 umgebaut und siehe, es geht dort. Das bedeutet, dass HEATER_3 umdefiniert und anderweitig verwendet wird in der vordefinierten configuration.h. Es bleibt die Frage, was dort angeschlossen wird, denn in der Dokumentation ist er frei.

    Hoffnungsvoll,
    Gunnar.

    #1518
    vincent
    Verwalter

    Hallo Gunnar,
    es gibt hier viele configuration.h Dateien zu finden. Bitte die Datei hier hochladen.

    vincent.

    #1519
    ghenne
    Teilnehmer

    Hallo Vincent,

    vielen Dank für deine Antwort. Es ist die in deinem Post:1292 befindliche Datei Configuration-MABL_ohne_Extensionboard.h auf die in vielen anderen Posts Bezug genommen wird.
    Aber ich lade sie einfach hier nochmals hoch.

    Es sieht so aus, als ob einige Anschlüsse gegenüber dem Verdrahtungsplan des Sparkcube 1.1 XL mit RADDS anders sind. Neben der oben stehenden Umdefinition von FAN_PIN:

    #undef FAN_PIN
    #define FAN_PIN HEATER_3_PIN

    finde ich unten auch noch:

    #define HEATED_BED_HEATER_PIN ORIG_FAN_PIN

    Da ist einiges anders. Ich versuche eine configuration.h herzustellen, die auf meinen Sparkcube 1.1 XL passt. Ich habe fast alle Teile im Shop gekauft und ihn streng nach dem Video aufgebaut und gegenüber dem Standard nur 100mm mehr Z-Höhe. Alle 6 Treiber sind auf dem RADDS 1.5 und steuern separat 3 Z-Motoren, sodass MABL funktionieren sollte.

    Mal abgesehen von dem obigen Problem mit der configuration.h:
    Ich tue mich leider sehr schwer mit der Verfolgung der ganzen PIN’s zu den Anschlüssen und der Zuordnung in der Konfiguration der Firmware, vielleicht könnte man das mal von Grund auf aufrollen und aufschreiben. Wenn ich die RADDS Dokumentation durchgehe komme ich auf folgende Zuordnung:

    
    configuration.h/Pins.h      Due Pin        RADDS MOSFET    Schraubklemme
    
    Heater0_PIN                   13                  FET 6                       Extruder 0 Heizung
    Heater2_PIN                   12                  FET 5                       Extruder 1 Heizung
    Heater3_PIN                   11                  FET 4                       Extruder 2 Heizung
    Orig_FAN_PIN                9                    FET 3                       Bauteil Lüfter
    Orig_FAN2_PIN              8                    FET 2                       Extruder 0 Lüfter
    Heater1_PIN                   7                    FET 1                       Heizbett
    

    Wenn das obige stimmt, dann ist aber im Verdrahtungsplan (hänge ich auch an) die Bezeichnung für Hotend Lüfter und Bauteil Lüfter vertauscht.
    Ich weiß, die ganze Doku verschlingt viel Zeit, erspart aber später auch so manche Nachfrage, wenn sie denn fehlerfrei ist 🙂

    Viel Grüße,
    Gunnar.

    • Diese Antwort wurde geändert vor 4 Jahre von ghenne.
    #1524
    SuperMario
    Teilnehmer

    Hallo Ghenne!

    Ich hatte das gleiche Problem. Der angefügte Anschlussplan stimmt nicht mit der Configuration-Datei zusammen!
    Ich habe nun auch das LED-Menü aktiviert und die Kabel gleich neben dem Hotend Lüfter Anschluss angeschlossen.
    Ich habe genau nach dieser Zeichnung die Kabel angeschlossen und folgende Einstellungen beim Repetier Onlineconfigurator (Ich habe einen Singleextruder) eingestellt:

    Heated bed: Heater pin: Heater 1 normally used for heated bed —> geht bei mir zum SSR-Relais
    Extruder: Heater pin: Heater 0 normally used for Extruder 0 —> geht zur Heizpatrone
    Extruder: Extruder cooler pin: fan pin —> Hotend Lüfter
    Print cooling fan pin: fan 2 pin —> Bauteillüfter (PLA)
    Case Light Pin: Heater 3 normally used for Extruder 2 —> Beleuchtung

    Ich hoffe dir damit geholfen zu haben!

    Gruß
    Mario

    #1526
    vincent
    Verwalter

    Die Modularität macht es mir schwer. Es gibt so viele Konfigurationsmöglichkeiten und mittlerweile viele verschiedene config.h Dateien.

    vincent.

    #1553
    SuperMario
    Teilnehmer

    Hallo Vincent!

    Vielleicht kannst du mir weiterhelfen?

    Ich habe nun das Case Light Menü aktiviert (DEV_Firmware) und sehe es nun im Displaymenü beim Sparkcube. Aber nun zu meinem Problem: Wenn ich während dem Druck in das Menü springe (USB-Druck) um das Licht auszuschalten dann bleibt der Druck stehen und erzeugt mir einen Blob auf dem Werkstück da ja das Filament nachläuft! Ich habe auch schon beobachtet, dass der Puffer von 64 langsam weniger wird, dann steht der Drucker und nach ca. 20-30sec druckt der Drucker weiter! Also ich kann während dem Druck nicht das Licht an-/abschalten . Gibt es da eine Abhilfe?

    Vielen Dank!

    Gruß
    Mario

    #1554
    vincent
    Verwalter

    Hallo Mario,

    das ist mir neu. Bitte lade mal die komplette FW hier hoch, dann gebe ich den Fehler an den Entwickler weiter.

    vincent.

    #1556
    SuperMario
    Teilnehmer

    Hallo Vincent,

    vielen Dank für deine Antwort! Ich habe das Problem schon beheben können. Das der Fehler nur bei USB aufgetreten ist, habe ich nun USB Steckplatz u. Kabel gewechselt und nun funktioniert es! Vielleicht war auch nur das Kabel defekt keine Ahnung.

    Gruß
    Mario

    #1560
    ghenne
    Teilnehmer

    Hallo Mario, hallo Vincent,

    abschließend möchte ich mich dafür bedanken, dass ihr mir auf meiner Baustelle weitergeholfen habt. Letztendlich habe ich gelernt, dass ich mir eine ganz eigene Konfiguration zusammenbauen kann, Ich wollte jedoch mich möglichst genau an die RADDS1.5 Pläne und Repetier Pindefinitionen halten und habe es nun so gemacht, wie ich oben in meiner Tabelle geschrieben habe. Das Case light ist dann an den Heater_2 Pin gekommen.
    Einen kleinen Stolperstein gab es in Form der 30mm Bauteil Lüfter bei denen ich -wie so viele andere- auf die Sunon Maglev 30101V2-A99 Version hereingefallen bin. Die sind nicht per PWM regelbar und drehen nur bei 100%. Ein 220µF Elko hat das Problem gelöst.

    Wir sehen uns dann als nächstes im MABL Thread. Bis denn….
    Gunnar.

    • Diese Antwort wurde geändert vor 3 Jahre, 11 Monaten von ghenne.
    • Diese Antwort wurde geändert vor 3 Jahre, 11 Monaten von ghenne.
Ansicht von 11 Beiträgen - 1 bis 11 (von insgesamt 11)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.