Ansicht von 11 Beiträgen - 1 bis 11 (von insgesamt 11)
  • Autor
    Beiträge
  • #2665
    Seha
    Teilnehmer

    Hallo,
    Ich versuche die MABL Firmware die ich hier im Forum gefunden habe zu nutzen, jedoch bekomme ich den Drucker nicht dazu zu „homen“ oder sonst irgendeine Bewegung auszuführen. Ich habe die Firmware etwas abgeändert, sodass ich einen 2. Extruder habe und ein BlTouch nutzen kann, könnte es sein das ich dabei etwas falsch gemacht habe? Ich habe mal den Schaltplan nach meinem Setup geändert und den Inhalt der Konsole beim „homen“ hinzugefügt. Ich habe auch noch kein FTS, plane mir aber noch 2 aus dem Sparkshop zu kaufen, könnte es aber eventuell daran liegen, dass ich keins eingesteckt habe?
    LG

    • Dieses Thema wurde geändert vor 8 Monaten, 4 Wochen von Seha.
    #2670
    vincent
    Verwalter

    Hallo, wenn sich gar nichts bewegt und elektronisch alles passt, liegt es vermutlich an den Endstops und deren Einstellung.

    Mit dem Befehl M119 kann man die Endstops testen. Diese müssen unbetätigt „L“ ausgeben und betätigt „H“.
    Alternativ kann man den Endstop Status auch im Display sehen.

    vincent.

    #2671
    vincent
    Verwalter

    PS: ich empfehle dir die 3 Motoranschlüsse für die Z-Achse genau aus dem MABL Thread zu übernehmen. Die Extruder kannst du überall anschließen, die sind in der Firmware schnell eingestellt.

    #2672
    Seha
    Teilnehmer

    Hallo,
    danke für die schnelle Antwort ich habe jetzt mal M119 ausgeführt und bekomme diese Antwort vom Drucker;

    Recv: endstops hit: x_max:L y_max:L z_min:L Z-probe state:H

    Eigentlich müsste das so richtig sein jedoch geht homen leider immer noch nicht, oder muss die Z Probe ebenfalls L im Status haben?
    Außerdem gibt es ein offizielles MABL Thread? Ich hatte die Anschlüsse einfach aus den Antworten von einem Frage-Thread über MABL übernommen.
    LG

    #2673
    vincent
    Verwalter

    Die Antwort gibt immer den aktuellen Moment wieder. Wenn du einen Endschalter auslöst, hältst und dann den Befehl sendest, sollte der entsprechende auch ein „H“ wiedergeben. Ja, auch der Z-Probe sollte ein „L“ anzeigen, wenn er nicht gerade das Bett berührt.
    Ob der BL Touch im eingezogenen Zustand H wiedergibt, kann ich jedoch nicht mit Sicherheit sagen.

    Ich habe mir die Endstop Konfiguration angesehen, die kann so nicht stimmen. Hast du den sparkcube modifizert, oder warum wurden die Settings hier angepasst? Es wurde die Homing Richtung immer in Max-Richtung definiert, jedoch gibt es z.b. für Z-Max gar keine Pin-Konfiguration.

    vincent.

    #2674
    Seha
    Teilnehmer

    Nein ich habe den Sparkcube bis aufs BLTouch, Kein FTS und TMC Treiber komplett „Original“, also muss ich etwas falsch konfiguriert haben oder ich habe eine falsche ausgangs Konfiguration genommen.

    #2675
    Seha
    Teilnehmer

    Hallo,
    Ich habe jetzt sehr viel versucht jedoch funktioniert leider nichts. Ich habe nun mittlerweile die Firmware von Dropbox heruntergeladen und genau nach „OptionA“ verkabelt aber „homing“ geht immer noch nicht.
    Versucht habe ich außerdem;
    Verschiedene Repetierfirmware aus dem Forum,
    Motortreiber getauscht,
    Schrittmotoren getauscht,
    die Schalter am RADDS „rumprobiert“,
    Motorkabel, Endstops, Stromversorgung des RADDS geprüft.

    Mir gehen langsam die Ideen aus woran es liegen könnte besonders da die Motoren sich ja auch „sperren“ direkt nach dem Einschalten und beim Verbinden zum Computer(Pi) „entsperren“ also sollte der DUO und das RADDS eigentlich in Ordnung sein. Hast du eventuell noch eine Idee was ich versuchen könnte?

    #2676
    vincent
    Verwalter

    Hallo,
    hier noch verlinkt die letzte Konfig und Hinweise zu deren Verwendung. Stimmen denn ansonsten alle Thermistorwerte? Als Motortreiber werden RAPS128 verwendet?

    vorkonfigurierte FW: https://the-sparklab.de/forums/topic/autoleveling/page/4/#post-1292
    MABL Verwendung: https://the-sparklab.de/forums/topic/autoleveling/page/6/#post-1433

    vincent.

    #2677
    vincent
    Verwalter

    PS: den zweiten Extruder würde ich dann auf das Extensionboard legen. Aber zuerst MABL Einrichten. Wenn Extruder oder Heizbetten definiert sind, müssen auch die 3 Thermistoren angeschlossen sein, ansonsten geht die Firmware in den Fehlermodus. Man kann in der Firmware bei Thermistortyp aber auch „fake thermistor 20°C“ auswählen, dann braucht man zum Testen keinen.

    vincent.

    #2680
    Seha
    Teilnehmer

    Hallo,
    Ich habe jetzt herausgefunden wo der Fehler war und zwar habe ich die Option „Invert enable signal“ für „Invert direction“ gehalten und deswegen nicht geändert. Ich nutze ja TMC2008/9 Treiber und nicht RAPS128 und diese benötigen ein „Invert direction“, dadurch wurden die Schrittmotoren Treiber immer ausgeschaltet wenn sie angeschaltet werden sollten. Jedoch was ist eigentlich der Grund warum der Extruder auf das Extension Board soll?
    Vielen Dank für deine Hilfe,
    LG

    #2749
    vincent
    Verwalter

    Jedoch was ist eigentlich der Grund warum der Extruder auf das Extension Board soll?

    Oh, ich hatte die Nebenfrage überlesen. Die Reihenfolge der Motordefinition der „additional drives“ und der Positionen sind wichtig, ansonsten kann die Firmware dass nicht zuordnen. Wenn man die Motoren Definition der Z Achse ändert muss man genau wissen was man tut.

    Daher ist es einfacher den Extruder auf das Ext. Board zu legen.

    vincent.

Ansicht von 11 Beiträgen - 1 bis 11 (von insgesamt 11)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.